Unhandled error when adding Craigslist RSS feed

I’m trying to update an old Craigslist RSS feed in NewsBlur with a new URL.

The URL works fine when I try it directly in my browser.

But when I paste it into Newsblur in the “Change RSS feed address” field, I always get “Sorry, there was an unhandled error.”

Here is the URL I want:


1 Like

This is still an issue. Today I tried a similar URL, but slightly different:


This URL works fine. But NewsBlur always errors out when I try to add it as a feed.

Did you copy the RSS feed url or the website address? Given the frame format I wouldn’t be surprised if Newsblur doesn’t like it, but I just tried the RSS button on the lower right which gave me a RSS link that seems to work fine (note the format=rss in the url).

Yeah, I simply pasted the wrong URL into my reply.

But the original URL I posted at the top of this bug report includes format=rss and is an actual RSS feed. It remains a perfect example of the problem, since NewsBlur chokes on it every time I try to add it as a subscription.

Looks like Craigslist is taking too long to return the feed. NewsBlur is timing out on fetching the feed. I believe Craigslist is intentionally limiting NewsBlur (as well as other RSS readers).