train-save-share buttons move occasionally

After scrolling through my feed on for a bit, the buttons will move from their stacked position at the bottom right of the article, to all on the same line at the bottom left of the article. They still work fine. I’m unsure of what the trigger is exactly.

Using Chrome 26.0.1410.65 on OS X 10.8.3.

1 Like

The trigger is the width of the story pane. However, I find the turning point value to be incorrectly configured and wish I could just keep the buttons in a bottom row 100% of the time so that I can get the width of my articles exactly how I want them without adjusting regularly…

+1 Karen.

At one point, I figured out about half the css adjustments needed to make this always show on the bottom, but I lacked the patience at the time to keep at it and get everything correct. Sam, if you can help with a list of the css that needs to be tweaked, that’d be awesome!

It’s a single class you just need to add: .NB-feed-story-view-narrow

However, you need to add that to four places. See adjust_for_narrow_window in…

I feel dumb… I know how to do that in html, but how would I do it in CSS? I’m a self-taught css-tweaker, and this is clearly something I’ve not yet run into.

I’m not sure what you are and aren’t able to modify, but if you know how to patch JS, just change that method to always use the narrow mode.

Yeaaah, I *definitely* don’t know how to do that :-/

I don’t understand. Do we save that file to our computer somewhere? What if we are using a portable browser? Where do we save it?

I am not a programmer and don’t know what to do with the reader.js file.

It would be nice if the user option to put the train-save-share buttons along the bottom and use the full width of the pane for the article.

1 Like

I was going to raise as a separate topic an option to move the buttons to the bottom of the posts permanently as that’s what I’d prefer, but seeing that this thread is here I will append this here for now :slight_smile:

It would still definitely be great to be able to turn this off. I want the full-width section 100% of the time!

You got it. I added a preference (Under Preferences > Stories > Story button placement) so you can move it to the bottom of all stories.

1 Like

You rock!!!