Switching back from unread-only feed view doesn't actually display all feeds

In Preferences -> Default Story Order, I tried out the new “unread only” feature just to see how that felt. When I changed to “unread only” and saved changes, NewsBlur correctly displayed only the unread items of a given feed’s sidebar.

I decided I preferred seeing all stories, so I changed the setting back in Preferences and saved my changes. I’ve tried refreshing several times, but I’m still only getting the unread items in my RSS feeds.

1 Like

Ack, this was a last minute feature that I launched yesterday and hadn’t had time to fully test. My apologies. So it goes on the bleeding edge.

Unfortunately, I can’t repro the issue. Here’s what I’m doing:

  • Right-click on a site and confirm it’s in Newest/All (as opposed to Oldest/Unread)
  • Preferences: change default to Newest/Unread
  • Confirm site only shows unreads
  • Refresh the page (to confirm it’s sticky)
  • Change default preference back to Newest/All
  • Confirm site shows all stories.
  • Right-click on site to confirm that it’s just showing the default.

As soon as you right-click on a site to change it to a non-default setting, that becomes sticky, and changing the default won’t change the site’s view setting.

Now, I could wipe out your view preferences every time you change the defaults, but I worry that this would lead to unintended consequences. Whereas if you manually set a site to be Newest/Unread, but changed your default around a few times, you at least manually set a site to be what you wanted.

I could offer a reset button, but that’s a hack and I don’t think I’m willing to do that. So let’s find out why.

Let me know if it’s every site or just one site. You should not have to go reset every site. I would be happy to wipe out your view settings, but that’s a last resort.

Hey! Yeah, it’s every site, and it’s being…weird. I’m definitely set to all stories (not unread). For every site, I see one “old” story that is marked as read, and then the new stories. The old/read story is at the top, because I’m using oldest-first (which I love, thank you for getting that in). This is happening in Chrome version 20.0.1132.57 m in case that helps track this down.

Ah-ha! OK, everything’s fine. It’s because Oldest-first uses the mark_as_read time. That can change, but is that not what you want?

Consider the circumstance: what date should oldest-first in all-stories start at (not unreads, cause that’s easy – it’s just your unread stories sorted oldest first)? I set it to use your last mark_read date. It could instead of the DAYS_OF_UNREAD flag, which is currently 14 days (see that thread on get satisfaction for gory details).

Make sense? If not, then you’re probably not the only one confused.

This one got me initially, too. Thanks for the explanation.

Ah okay, this makes sense. I guess what I was expecting is for oldest-first to look more similar to newest-first…with newest-first I’m taken to the newest unread item, and I can scroll down through the history of read items, so I was assuming oldest-first would take me to the oldest unread item and let me scroll up through the history of read items. This makes sense though, so I’ll switch back to newest-first, since I’d rather see my history than read in chronological order, if I have to choose between those options.

I absolutely can switch it to a different kind of “oldest-first”, going back 2 weeks and just pulling the reeeeeally old stuff. But I try to be smart about it and only go back as far as you’ve marked as read. And really, this is only if you use the Oldest/All stories setting. The intention is to use the Oldest/unread-only setting, since that’s why you’re Oldest first. Otherwise you’d use Newest first.

I think the real lesson here is that it needs better messaging, but how I do that I have barely a clue. It’s a pure design problem and I haven’t been particularly strong in that area.