Subscription renewal ios not coming through


My subscription renewal on newsblur was made in March via ios. I did get a message in April that my subscription was coming to an end but I did not pay attention to it as I assumed it was some kind of bug. However, some days ago my premium newsblur account was downgraded back to a normal account. When going through the payment history in newsblur, I indeed cannot find the subscription renewal although it did show up on my cc. How should I fix this?

In addition, I encountered the same error previous year. Is it better to not use the ios subscription renewal service in the future and just do it via your website?

I don’t know why the iOS subscription service fails. I’m logging every request that comes in from Apple’s servers and it’s like the request doesn’t come through.

What’s your username? I’d be happy to manually upgrade you.

As for the issue behind this, I’m launching the new beta in June and that should give me more insight into what’s happening.

Hi Sam,

Thanks for coming back to me. My username is evilstinky.

Thanks, I’ve fixed your account. Oddly, the previous two years came through just fine, so it doesn’t seem account-specific but rather event-specific.

Hi Samuel,

It does not seem to be fixed from my side. My account is still no premium account.

Ok, your account should be ready to go. With the new iOS app coming soon, next year’s renewal should work fine. Let me know if it doesn’t so I can take a deep dive.

Hey Samuel I think I ran into the same thing. I found this form while searching to see if anyone else had run into this issue. I got the email that I had the grace period month (good idea for that feature by the way) even though the iOS subscription had renewed a few days earlier (May 31).

Can you help to get my account set back up with the subscription? Let me know if there’s anything else I may be able to help with to debug the issue too!


Sure, what’s your username?

I have posted a ticket to try and get it resolved, but I’m not sure why it works 99% of the time but not always.

Thanks for the super fast response!

My the username should be the same as the one here on the forums: NonyNewsBlur

Hello Samual,

I have the same issue. Paid for Premium on my iPhone and my account has not been upgraded.

User name: dridge987

Hi @dridge987, I checked and it looks like the iOS payment went through just fine. Check your account on the web to confirm, but you should be all set.

Yes after a while I decided to click on the restore function in the app and after doing that a couple of times it finally worked