"Story" option not working

My stories are not loading what I click on the “story” option in the browser version of Newsblur. They will be deemed “read”, but will not actually show.

In addition, any youtube videos that are linked within any feeds just appear as blank boxes where the video should be.


I’m seeing the same behavior

Firefox and Chrome are blocking Mixed Content.
In Firefox, click on the shield icon on the left of the URL bar and allow mixed content
In Chrome, the shield icon is on the right.
This will reload the page, so any story you have tried to read will be marked read, so you might want to mark it unread before allowing mixed content.

1 Like

Well, hey, that does indeed fix it! Thanks Sean!

This is not my experience, Sean… I don’t even have a “shield” icon present, so can’t show mixed content!

I don’t have a shield icon either.

But this only seems to be happening to one of my feeds, The Politics Blog with Charles P. Pierce. Unfortunately, that’s one of my favorite sites…

Currently, switching from Chrome to Safari has worked but I do not want this to be a permanent fix! Please help with figuring out to fix Chrome, since I do not have the shield icon.

The shield icon will not appear till you view a story in story mode, which is what triggers the mixed content. Image of icon is below.

1 Like

Oh, bless you Sean! Thank you for that more in-depth answer!
By any chance, do you know if I have to click that for every. single. article. that behaves in this manner?

Not for every story, but every time you reload the Newsblur UI. It’s really annoying.

1 Like

That is extraordinarily annoying…
But thank you!

The easiest fix is to use http and not https. http://www.newsblur.com. Make sure you turn off the secure option in Preferences, otherwise it’ll just redirect you to https.

Samuel, I do not have SSL turned on within the NewsBlur preferences, but this problem was still occurring up until Sean walked me through how to allow the unsecure site.
Do you know if there’s any permanent fix? Or why this just started happening a couple weeks ago? I’ve been using NewsBlur for a while now, and it only recently started. I should say that I do not know if this occurred with a browser update.

Jamie, It’s a recent change to Google Chrome and Firefox that has blocked mixed content by default. Within the last month or so. Since both browsers update automatically by default, most users are unlikely to notice the change in browser behavior, and think it is a site specific issue. I don’t think this change was well handled by Google and Mozilla.