Stories no longer appear in List View

I just logged into NewsBlur at home and List View seems to be broken. Clicking on the title of a story or scrolling through using j/k does not open the story anymore. It will highlight the title and mark the story as read, but I don’t see the story.

Switching from Feed View to Text View, or from List View to Split View and back, will sometimes show the story, but the problem reoccurs after scrolling through a few stories. Using Firefox 21 on Windows 7.

Could this be related to the fixes just deployed earlier today for Single Story mode? This was working earlier today at work (on Chrome) and I do have “Show a single story at a time” selected in my preferences.


It is definitely related to “Single Stories” mode, as I just disabled the preference and I’m not seeing any issues now.

Also, when I went into Preferences, discovered this quirk:

  • I’m in List View with Feed selected, I hit the keyboard shortcuts to scroll through the story list, and it’s highlighting the story titles without opening the stories. If I open “Preferences” or do anything else that pops up a window (such as hit “T” to bring up the intelligence trainer) the story will appear.

Just deployed an update. All should be well now.

When I switch back to single story mode it still isn’t fixed… if disabled it still fixes the issue though

Have you reloaded? If it still doesn’t work, let me know your username.

Same problem here.

Just tested on both latest FF & Chrome on win 7, isn’t working on both. However if i resize/restore window size the article is then displayed. Hope that helps.

Reloaded with hard refreshes and browser restarts, still happening for me. Username: deezil

+1, Me too, etc.

This morning the j/k and n shortcuts wont working, now it will scroll but it won’t display the text.

Just tried the left-right arrows to navigate between stories and those work and expand correctly, looks like it’s just the j/k shortcuts.

Never mind. I thought it was going, but it was actually just scrolling the same story and I wasn’t paying attention.

Good news, just fixed this. It’s because you had the single story mode turned on but also in List view where it wouldn’t apply. Refresh and it should work perfectly.

1 Like

Just turned single story mode back on to test and it’s working now. Thanks!

So single story mode doesn’t do a thing in List view. But if you switch back and forth between List view and Split view, then it’s worth having on.