Some feeds no longer work with new text view

Following the recent change some of the feeds that worked before in text view are no longer able to retrieve text.


I’m seeing some of this as well; additionally articles that are referenced by the first party post are taking over the text view. (I don’t know if that was the case before or not.) Prolly shouldn’t tho.

Got any specific examples? I have both the old and the new text view working, so if the new text view doesn’t extract any data, then the old text view will give it a try. If you aren’t seeing that happen, then it’s likely that the new text view is finding something, just not the right story. I’m not sure if I can work around that because there may not be an easy automated way of figuring it out. I do compare the length of the text extracted, but that may not be enough.

This happens to me with Ars Technica. Some articles work fine, others bring up a message saying “Sorry, the story’s text could not be extracted”. The feed worked flawlessly prior to the switch the new text extraction method.

Example stories from which the text could not be extracted include this one and this one.

Edit: just noticed that this is categorised as iPhone and web app, but I’m experiencing it on both the web app and the Android app (v7.0).

Edit 2: More examples from a different feed here and here (again, many stories from this feed work fine, but others show the same error described above).


Didn’t see your reply until this last one. is good example one that used to work.

CNet’s feed is litered with them. Occurs on both iOS and web. Feed link to a specific story is this: