RSS feeds for tags not created correctly

#1

Newsblur used to create individual rss feeds for user created tags, but in recent days I have noticed that this is no longer the case.

My previous tag feeds look like this:

http://www.newsblur.com/reader/starred_rss/427931/XXXXXXXXX/TAG

All new tags are created with the same feed address, like this:

http://www.newsblur.com/reader/starred_rss/427931/XXXXXXXXX/

(so basically the same, but without the tag on the end)

I’ve tried manually adding the tag, but I just get a 404.

#2

Just checked and RSS feeds for tags are working so I’m curious as to what’s going on here. Mind sending the url to samuel@newsblur.com?

#3

Hi Sam,

Thanks for replying. Not sure what I can send that will help. These pictures might?

Here’s how a regular tag for a saved story looks to me:

Now here’s two that have just been created from saved stories - both have the same url, and no tag appended on the end:


#4

Hi,

I’m still having the same problem. Unique feeds for saved tags are not being created. They all have the same URL.

Is there something that I can do to help diagnose this?

This appears to be the same issue raised here: Saved story tag feed URLs don't always have the tag name

EDIT: I have a correctly generated tag feed now. I’ve no idea how, or why, but I have. I’ve just tried to create another one, to test, but same issue as previously. Maybe there is a time delay?

#5

I’m not sure what happened but when I went to check it looks like the tag is being correctly appended. What browser are you using?

#6

Hi Sam,

I’m using Safari on macOS Catalina. I’ve also tried Safari mobile and Edge Beta for desktop. Same on all.

I’ve done a screen recording - if that helps?

#7

Oh it looks like that’s on tag creation. If you reload the page, the Hello tag should work, right?

#8

Sadly not.

The Hello tag still comes up as a url without the tag on the end, and if I manually add the tag to the end of the url it just comes up as 404.

:man_shrugging::slightly_smiling_face:

I’ve got five saved tags at the moment but only three of them have fully formed tag urls. The rest just point to a url for all saved stories.

#9

Amazing job documenting this. I finally found the issue and fixed it. I also tested your URLs and they should now work. Thanks so much for your persistence.

1 Like