Rendering broken on Android app

#41

okay, i’ve joined the android system webview beta, we’ll see when it offers me an update

#42

I think it’s uninstalling all the updates that fixes Newsblur, not using Chrome Beta.

You can’t uninstall Chrome…

#43

I think you are right.

I tried removing Chrome Beta and Newsblur still worked, but as soon as I re-enabled regular Chrome the rendering died again. I then disabled regular Chrome again and the rendering was fixed.

Chrome Beta is good temporary work around though.

#44

android system webview 75.0.3770.16 from the beta program does not fix it.

1 Like
#45

Chrome Beta isn’t fixing things- what is happening is you “uninstalled” Chrome, which took chrome back to the baseline (eg before any updates). That’s what @tuck was saying.

So… there’s no fix/workaround here other than a bad one, going to an ancient version of Chrome.

2 Likes
#46

Apologies if I phrased it in a way to say beta fixed it. I was trying to say that uninstalling all chrome updates fixes it and then using Chrome Beta doesn’t break it, but allows you to use a version of chrome rather than switch to a different browser.

#47

That’s a good point, may certainly be an improvement…

#48

Good news, I’ve just hired a new Android developer and he begins tomorrow working on the API updates necessary to get this fixed. I hope the update will be out within the week.

8 Likes
#49

Ok, we have a new fix for the time being. Caleb, our new Android developer, discovered that the new upcoming OS-wide dark mode is causing the issue.

In Chrome, go to chrome://flags and set the flag #enable-android-web-contents-dark-mode to Disabled . Then you’ll need to kill/restart the NewsBlur app in order to reload it.

We’ll have an official release as soon as possible, stay tuned!

1 Like
#50

Good work Caleb!

I don’t suppose there is any way for those of us without Chrome (and thus are using Android System WebView) to address this? I guess I could install (re-enable) Chrome for the time being and let the system use its rendering engine.

UPDATE: I tried this, but it unfortunately didn’t work: re-enabled Chrome, updated to the latest version, then set the flag to Disabled. Killed and restarted both Chrome and NewsBlur, but the rendering was broken. So, I disabled Chrome again and – so long as I don’t update to the latest Android System WebView – all is well again with the NewsBlur rendering. (If it matters, this is on a Samsung Galaxy S7 running Oreo.)

1 Like
#51

I tried this on my Android/Samsung tablet and after changing the Chrome flag the ‘theme’ setting does not open in Newsblur. I restarted the tablet after forcing a stop on the Newsblur app. Theme setting doesn’t open whether that Chrome flag is set for default, enabled or disabled. Weird.

#52

This worked on a Moto G7 running Pie, but did not work on a Pixel 3 running Q Beta 3 which isn’t entirely surprising.

#54

Thanks. The chrome://flags trick worked for me on Note 9 Pie.

#55

I have disabled the Chrome flag and it worked initially. Lately it stopped working (despite flag) and I need to kill Newsblur several times for it to display text correctly…

2 Likes
#56

The flag does not work for me either. Desactived the standard Chrome app and disabled the flag in the Chrome beta. No change.

2 Likes
#57

Over two months now, and still no resolution. This is beyond maddening.

2 Likes
#58

12 days ago the ETA was “within the week”. Any update?

1 Like
#59

I pushed on our new Android developer to get a resolution. It’s going to take some more work I’m afraid. You can follow the ticket to watch it happen in real-time, for what it’s worth: https://github.com/samuelclay/NewsBlur/issues/1178#issuecomment-492849604.

In fact, I just noticed that Caleb asked me to release a build 2 hours ago. So I’ll get on that now and try to push it out to the beta channel.

1 Like
#60

webview beta 75.0.3770.40 came out today but does not fix it.

1 Like
#61

what/where is the invite to the beta channel, Mr. Clay?