Rendering broken on Android app


#6

Well, I can’t use any other theme - my eyes are literally bleeding… :(((


#7

As a temporary fix - on some devices, it may be possible to go into the Google Play store and uninstall the update to the Google Chrome WebView “app” that recently updated.


#8

Can confirm rolling back the Chrome update makes NewsBlur rendering work again.


#9

How do you roll back the Chrome update?


#10

settings - apps - android system webview - uninstall updates

this drops it back to the version that came with the last major OS update for the phone, not the last individual update through google play. that may be farther back than you want to go, on an older phone.


#11

Had the same issue for the last several days, finally came to the forums and glad I found this.

I uninstalled Google Chrome from the play store as mentioned above, which resolved the issue.


#12

Android 9 here. Android system webview is disabled. So far as I understand Chrome has replaced it from Android 7 onward. I have uninstalled Chrome updates and that solved the issue. Cannot completely uninstall Chrome since it’s part of the OS (Android One).


#13

I strongly recommend that you do not roll back Chrome updates, since those updates typically include security fixes that will leave your device vulnerable if you uninstall the updates.

The better approach until Samuel can get this fixed is to use the dark mode. That way you still have functionality in the app but also have full security via the Chrome updates.


#14

Dark mode it is… not so good for my eyes :expressionless:


#15

Forced to dark mode too. Please fix this.


#16

Any idea on when this is going to be fixed?


#17

new webview update dated 3/26 is supposed to be “Bug fixes and speedy performance improvements” but does not fix this for me.


#18

Broken for me as well. Webview was disabled, so removed Chrome updates, which resolves Newsblur problem.

Any word on a fix?


#19

Seriously, that’s major thing for (paid, as me) users. Please fix it ASAP.
Thanks in advance


#20

Completely agree. This is getting ridiculous. I’m extremely frustrated with the lack of attention. The last comment from Samuel Clay was two weeks ago with no update since then to even say he is working on it. I understand he was on vacation for a week, but he has been back long enough to devote some time to this.


#21

OTOH Mark as read icon has been “fixed”
Priorities!


#22

So the good news is that we’re working on it and should have an update out within the next week (I hope!). What happened is that Google pushed out an update to Chrome that caused our web renderer to misapply a style. But the issue is that we need to upgrade to a later Android API in order to release a new version and that’s a substantial chunk of work, of which we’re in the process of completing. I promise that this is our highest priority and we’re working on getting it fixed ASAP.

A temporary fix is to use the dark theme, but I realize that’s a non-optimal fix. But it works for now.

If you’d like to follow the ticket that’s tracking this issue, it’s on Github:


Android: screenshot attached of the issue
#23

Thank you Samuel - I appreciate the update!


#24

The good news is that rolling back the Chrome updates means that XKCD cartoons once again appear in Newsblur!

Thanks for the update. Figured this wouldn’t be a trivial fix.


#25

No news on this 12 days? Any update on this?