Problem with Intelligence Training and Story Titles

I’m not sure when this started, but I noticed today that some stories I was sure I had trained to be filtered out were appearing in my feeds. However, when I looked at the Intelligence Trainer data for the feed, the phrases indeed weren’t there.

Figuring user error, I tried to re-train a story. I selected the part of the title I wanted to use for filtering, hit thumbs down and then “Save training.” The trained story (along with others matching the criteria) shows in list mode with its icon turned red. In other words, all indications are that the training process worked fine.

However, once I closed and re-opened the feed, the stories appeared once again. If I open Intelligence Trainer for the feed, what I just trained does not appear in “Titles and Phrases” (title phrases I have trained in the past do show up).

Tried the same process in another feed – even tried another browser – same results.

On a whim, I trained a story by tag, and that worked fine…so it appears that it is only title-based training that is broken for me.


So is it only a specific direction? I trained this story with no issues, so I’m trying to figure out the pattern for where it doesn’t work.

In feed view (before I trained “Story Titles” to be negative):

In river view (after I trained):

Not included are the complements to these: the feed view post training and river view pre-training. But this should cover everything, so I’m trying to figure out what this is happening on.

Both directions (should have mentioned I tried that as well). My training looks like the above, and after training the river (well, list in my case) looks correct as well.

However, it doesn’t “stick:” any “red” articles not marked read when closing the feed reappear if I look at the Intelligence Trainer data for the feed, the phrase I just trained has not been added to the list.

Before training:

After training (not shown) on “Intelligence” in title:

After training, looking at Intelligence Trainer for the site:

Again, this is only for title-based training; authors and tags working fine. It also started sometime recently, as phrases I trained in the past are still there and working; I just can’t add newly-trained title phrases.

Bumping this. This is still happening for me…if title-based training is working for others (as it appears to be), then it must be an account-level bug? It happens to me on multiple computers and browsers.

Bumping again. I still can’t get any new title-based training to “stick.”

Bumping again. Training is one of the features that led me to Newsblur, but it’s partially broken for me now.

I’m having the same problem. I can define title based training in the list view when right-clicking on an article… or when reading the article… and in neither case is it consistently “sticky”. In other words, when I update the list of articles, the title-based training is lost. I’m finally getting around to using training, and this is making it useless.

Well, glad to know it isn’t just me! I guess training isn’t used as much as I assumed, or people aren’t noticing the problem (as you know, everything appears to work fine)…or we’re just cursed :slight_smile:

There’s nothing particular to an account that would make this not stick. I’m trying it now and it works fine. What’s your username?

For me, cahwyguy

I’ll note a good forum to see this with, on my RSS feeds, is the Ipod Discussions for Itunes for Windows. I keep trying to filter on numerous things there that don’t stick.

What’s the url of that site?

My account is bwaldron.

For me it is not site-specific; I cannot do title-based training any longer on any site, even those where I have existing training data from when it was working (and these existing rules continue to work).

I have it happen on a number of sites.…

is one of them, but I’ve had similar problems with Mental Floss, Boing Boing, Buzz Feed, and others.

Bill, it’s not your account, as I just logged in and was able to train a word on the “Tampa Bay Times”, which you should find if you right click it and open the trainer.

I’m thinking something is going on in JavaScript on your browser. What browser do you run? Version and OS, too, please.

Yes, I do indeed see it (Hillsborough in green).

I originally thought something Javascript-related as well…but what threw me off that trail was that it is happening on both browsers I have installed: Firefox 22.0 (what I actually use) and Internet Explorer 10.0, both on Windows 7 Professional. The same thing is happening on another Windows 7 box here, running the same browsers.

For all I know, it never worked in IE – I only tried it for testing…but I know it worked in Firefox 21 – I’ll try downgrading and report back.

Thanks for helping chase this down – I know you’re busy!

Odd thought – Could it be a problem between the site trainer and the story trainer? With me, the sticky problem appears to be in the story trainer side – in particular, I have the expectation that titles I train in the story trainer migrate over into the site trainer settings for that particular site. They don’t appear to do that. I have no idea where the story trainer settings go, how I can review them, or if they are sticky. Are there (in fact) two different trainers (you can see them in the intelligence trainer – one says “for this site”, the other says “for this story”)

To be a bit more specific: What it looks like is training on TITLES in the story trainer do not migrate over into the site trainer settings, but training on keywords and authors do. I’m seeing this in Firefox on Windows 7.

Well, I downgraded to Firefox 21 and still no go. I’m seeing what cahwyguy is…keywords and authors work, title phrases don’t (they appear to, but never show up in the site training, so the training “disappears” the next time the site is re-opened).

I’m at a loss from my end. I wish I knew the exact date this started happening to help pin things down.

Bill, I tried again in your account on both a single feed and in a folder, and both times it worked perfectly. I’m not sure what’s going on, because I’m fairly sure that training works in Internet Explorer, although I could double-check. Can you try Chrome?