Problem: Only comments of site showing up in feed

When I add this site (, only comments appear in my feed. How can I change this to show the actual (non-comment) entries on the site?


Right-click on the feed and go to Site Settings. You can put in the correct feed address there.

1 Like

I’ve had this problem with a couple of blogs that I’ve ended up deleting for the time being. I get it 100% of the time with I add it and it just grabs the comments feed. I fix the feed and it either just reverts to as soon as I close the Site Settings or says it failed to fetch the feed. It’s also coming from feedburner ( redirects to, so maybe that’s involved in the problem?

Andrew: I was having problems with it reverting just like you mention. After fixing the feed, I closed Newsblur and reopened, and the fix remained. So far so good.

Jeff: I tried that, but when I reloaded, it has the orange !, and when I check Site Settings the feed has a “SAX Exception (553)”, so there must be some mangled XML in the feed or something. I guess that’s a different problem then, leaving aside the initial problem where adding the blog adds the comment feed instead.