open story in new tab doesn't open a new tab

I’ve noticed earlier today that some of my stories never got opened in a new tab. I generally use ‘v’ top open new stories in a background tab with the ‘loadDiveretedInBackground’ in firefox. However, I’ve also tried ‘o’ and ‘shift-v’ in firefox and chrome. I’ve also tried to disable the ‘loadDiveretedInBackground’ in firefox.

Steps To Reproduce:

  1. Go to a story
  2. Hit ‘v’, ‘o’, or ‘shift-v’
    Expected:
    A new background tab is loaded (or worst case foreground)

Actual:
A new tab shows up for a second in the tab bar but then closes immediately.

1 Like

I just tried it on my work machine and it works fine in that firefox but not in chrome.
At home I use firefox aurora (which is up to version 39 or something) and I have stable chrome (42) on both machines.

Seeing the same problem with Chrome 42.

i, too, am seeing the problem in chrome (v40.0.2214.95). it opens a new tab, which then immediately closes.

multiple feeds seem to have this problem, but here are 2 of them:
http://feeds.feedburner.com/tlofeed
http://feeds.feedburner.com/TheFaderMagazine

the first of those feeds has intelligence training, the second does not. 

\ *edit * it turns out, feeds that point directly to the source location (aka eater.com, humansofnewyork, flickr), rather than bouncing through a third party, work fine. i’m only seeing this problem with feedburner feeds, and feedproxy.google.com feeds.

Huh, weird, you’re right. It does seems like it’s only feedburner feeds that are broken like this.

The weird thing is that if you copy the feedburner url (right click title, copy address) and open it manually, it works just fine.

yup, that’s been my workaround. yay computers!

Also having this problem on Firefox 37.0.2 for a number of sites (BoingBoing, Slashdot). The new tab opens then immediately closes, almost like Firefox is blocking a pop-up.

Seeing this as well in Chrome 43.0.2357.45, starting today. Funny enough, if I hit Ctrl-Shift-T to reopen the last closed tab, the tab that was just closed comes up correctly, so that’s kind of a workaround for now.

1 Like

Hi folks. It sounds like the problem might be related to Adblock in some cases. There’s an open bug that describes exactly this, as the same thing started happening to me today for links on Facebook too.

http://support.getadblock.com/discussions/problems/79374-facebook-links-wont-open

tl;dr: Go into the Options, select Filter Lists, and click Update Now to get fresh definitions. This appears to solve the issue for some people. I’ll watch Newsblur to see if it resolves it there for me too.

(In the case of the Facebook tabs being blocked, Ctrl-Shift-T was NOT working. Alas.)

1 Like

Interesting. I’ll have to check it out. Though, I’m using ublock and not adblock plus, but it uses the same definitions list.
I’ll post with my findings when I get back home later tonight.

Just realized that my local chrome had the same issue. I updated the definitions and it seems to be working just fine now.
Good catch.

Seems to have solved the problem for me, thanks!

well hot dog, that seems to work! OR it was just incredible timing. we may never know.