Navigating feeds/folder is broken since yesterday

I was able to navigate with j/k and Shift + j/k and all was good until yesterday.

Now, when you navigate with “j” and there are unread stories in the folder, “Shift+j” works, but when you have read all of them, and try to go to the next folder with “Shift+j”, it doesn’t work.

I have noticed also that often when you have read all stories in a folder, even the first click with the mouse on another folder is not working.

I am very used to navigate with the keyboard, and really hope that this will be fixed.

1 Like

I am using Chrome 55.0.2883.87 (64-bit) on Linux.

Yes, this is likely as I just pushed a major rewrite for how the feed list is drawn. Can you post a full browser screenshot so I can see what’s going on? I can’t reproduce the issue on my end, so it’s likely to be a combination of view settings.

The problem seems to be fixed now, tested with a few folders, and now it works like expected. Have you changed something? I can post a screenshot, but maybe it will be better to do it when/if I am able to reproduce this again.

I probably fixed it then as part of another fix. It looks good to me now.

And it is broken again, attaching screenshot. “Shift + j” is not working in this moment.

THat’s a tough one because I just loaded in your view settings and it’s been working fine. Anybody else having the issue?

I have noticed that when the issue occurs, there is an error in the browser console, I hope this helps:

common.js?1481930514:1493 Uncaught TypeError: Cannot read property 'get' of undefined at d.load\_feed (common.js?1481930514:1493) at d.load\_page\_of\_feed\_stories (common.js?1481930514:1262) at d.check\_feed\_view\_scrolled\_to\_bottom (common.js?1481930514:1867) at u (common.js?1481930514:1014) at d.trigger (common.js?1481930514:1012) at d.\_onModelEvent (common.js?1481930514:1030) at u (common.js?1481930514:1014) at d.trigger (common.js?1481930514:1012) at d.set (common.js?1481930514:1017) at common.js?1481930514:1607

I am also having this issue (and I am also on Linux, but using Firefox).

Does it work at first and break later or does it break consistently? What are your usernames? I can take a look in your account and see what happens.

It works at first, but on the second or third folder I try to read, when I navigate to the last story, and try to go to next folder with “shift+j”, the error above occurs, and it is in a strange state (there is a blinking blue line on bottom, like loading something, and when you press “shift+j” again the current folder highlight goes above “global shared stories”, screenshot attached. My username is “hrhristov”.

For me, it sometimes works at first a couple of times and then starts breaking. Then, if I hit and go into the feeds again, it will sometimes work again. Also, when it starts breaking, changing feeds via the mouse is also not really working until I escape and try again.

My username is ‘gkatsev’

I can provide a teamviewer connection to a browser, where this can be easily reproduced.

I logged in and cannot for the life of me reproduce the issue. I tried reading a bunch of stories (and then marking them unread) and could not repro it. Is there a way you know of to trigger it?

I think I figured out how I can trigger it. It seems like it breaks if you finish reading a folder fully before trying to go to the next item. It seems to be working great for folders that still contain items. Even if you read some items before moving on it works. But if you mark *everything* in a folder read and then try to move to the next folder it won’t let you. Even then it doesn’t happen every time but if you continue it happens eventually.
Here’s the console log:

[Error] TypeError: undefined is not an object (evaluating ‘this.feeds.get(a).get’) load_feed (common.js:1493:395)
load_page_of_feed_stories (common.js:1262:240)
check_feed_view_scrolled_to_bottom (common.js:1867:510)
u (common.js:1014)
trigger (common.js:1012:257)
_onModelEvent (common.js:1030:482)
u (common.js:1014:84)
trigger (common.js:1012:267)
set (common.js:1017:83)
(anonymous function) (common.js:1607:162)
forEach (common.js:966:108)
(anonymous function) (common.js:1031:104)
deselect (common.js:1607:125)
reset_feed (common.js:1198:273)
open_river_stories (common.js:1224:109)
show_next_folder (common.js:1175:467)
show_next_feed (common.js:1174:538)
(anonymous function) (common.js:1459:197)
handler (common.js:230:164)
dispatch (common.js:116:365)
handle (common.js:110:195)

1 Like

Exactly the same with me.

I’m not using the keyboard browsing method, but seem to be having a similar problem. After the initial load of the site, trying to use any of the site buttons (next unread and home for sure) produces the following error in the console:

Uncaught TypeError: Cannot read property ‘get’ of undefined
at d.load_feed (common.js?1482182083:1493)
at d.load_page_of_feed_stories (common.js?1482182083:1262)
at d.check_feed_view_scrolled_to_bottom (common.js?1482182083:1867)
at u (common.js?1482182083:1014)
at d.trigger (common.js?1482182083:1012)
at d._onModelEvent (common.js?1482182083:1030)
at u (common.js?1482182083:1014)
at d.trigger (common.js?1482182083:1012)
at d.set (common.js?1482182083:1017)
at common.js?1482182083:1607

I’m seeing the issue pretty consistently today. I have about 1600 feeds (user alvinashcraft) grouped into folders. After I navigate to a folder and click through the unread feeds and try to click on another folder, it doesn’t navigate away. It just refreshes the current view. I have to click a second time. If I click the Mark All Read button, that action does auto-navigate to the next folder as expected.

Good news, I was finally able to reproduce it and fixed the bug. It could have unintended consequences, but I’ve been squashing this bug for two weeks and I think this will fix the last bug as part of the rewrite.

You should also notice that the Text view is now per-feed when reading by folder. That matches iOS and was intended to launch with the upcoming dashboard river.


I can confirm it is working now, thank you Samuel!