Muted feeds keep coming back after being deleted

#1

I have 3 feeds (one of which is “High Scalability”) in my account that are muted. When I try to delete them, they appear to be gone, but after a while reappear (muted again).

This also seems to happen if I unmute the feeds before deleting them.

#2

What’s your username and what’s the offending feed?

#3

There are three:

  • Drunk on Software
  • High Scalability
  • Kai Steinbach’s Blog
#4

Username is richardfearn. Thanks!

#5

I tried uninstalling the Android app from my phone in case it was caching something, so for the last day or two I’ve only been accessing NewsBlur through the website. Problem still occurs. I delete the feeds and sooner or later they reappear.

#6

I have the same problem with http://news.yahoo.com/world/

username: animaux

#7

I’ve been trying to understand what’s going on here. After deleting the muted feeds, when reloading the NewsBlur website, the home page briefly appears (as expected) and shows I have 93 sites (the correct number).

Then at some later time, when reloading the website, the home page shows I have 96 sites (the first hint that the muted sites are coming back). At this point though the muted sites aren’t yet shown in “MUTE SITES” (93/93) or “ORGANIZE SITES” (93).

Eventually they do start showing up in the UI.

1 Like
#8

I’ve noticed the feed number change, too, but mine does stay muted.

#9

I guess there’s no solution to getting a feed to delete completely so I do not have to mute it?

#10

Ok, sorry about the wait on this. I finally fixed the issue. If you see a deleted feed pop back up, once you delete it it will now stay deleted. The issue stemmed from how NewsBlur handles duplicate feeds and that merging process accidentally left the old duplicated feed in your account. When you deleted the feed, you were deleting the original feed, not the duplicate feed, so a background cleaning task would find the duplicate feed unsubscribed and resubscribe it for you.

#11

Thanks for taking a look at this! Unfortunately when I delete the three feeds mentioned above, they still keep coming back after some period of time. Has the change been deployed?

#13

I should mention that you’ll have to go through another round of deleting them before they stay deleted. The last time it finds the feed, it rewrites it so you will no longer be re-subscribed to it once you delete it again.

#14

awesome! two fixes in one day! thanks…

#15

Sorry but this still doesn’t seem to be fixed :frowning: I tried removing the feeds a couple of times on Tuesday, but they came back.

Yesterday (Wednesday) at 14:17 (UK time), the three feeds were in my account, and I deleted them. I immediately got the “Backup OPML file” email. When I then refreshed NewsBlur in the browser, it said “93 sites” (correct), and the feeds were no longer there.

When I logged into the webapp at 17:20, it still said “93 sites”, but when I did a hard refresh, it said “96 sites” - but the 3 deleted feeds still weren’t visible in “MUTE SITES” or “ORGANIZE SITES”.

At 21:18 I refreshed the app, and the 3 sites came back. They were also visible in the webapp until just now (Thursday 18:16) when I deleted them again.

#16

sad, but true. I see my muted site is back, too.

#17

Usernames and feed names would be helpful so I can take another look.

#18

See my Apr 21 messages in this thread. Thanks!

#19

username: animaux
feed: http://news.yahoo.com/world/

#20

any update??

#21

I’m also still having this problem. My NewsBlur username is richardfearn, and the three problematic feeds in my account are:

  • Drunk on Software
  • High Scalability
  • Kai Steinbach’s Blog