iPad app behaves all weird

I’m using the iPad app version 4.6.1 on an iPad Mini with iOS 8.1.2, I think the app was automatically updated some days again.

Since then several things stopped working. For example the “Send to” option no longer works as before, I simply get no dialog asking about the desired action. When switching to the Original View the app tends to crash when selecting any option like “Open in chrome”.

Also some articles show no images inside NewsBlur, for example this one:

There is just some kind of placeholder instead of the actual image. This happens in the default view as well as in the original view. 

1 Like

Using the new Newsblur version on an iPad with the OLD iOS (no, I am not upgrading yet), I also see weirdness, just a different kind.

Sometimes (I can’t give you repro steps yet), the items in the nav panel on the left escape their container and cover 2/3 of the screen.  They COVER the reading pane on the right, which is still underneath, but you can only see the right half of it.

This is in landscape mode.  If you rotate the device to portrait and then back, it seems to fix itself.

This is very annoying.

I also see the issue from Ken, sometimes the view is all messed up, after changing the orientation.

I fixed a ton of issues, some iOS 7 only, and some for both iOS 7 and 8. I hope this upcoming release addresses all of the issues. Many of them were layout rendering bugs.

1 Like

So there will be a new version soon? Because I’m using version 4.6.1 right now and there is no update for the app available (yet).

The issues remain, for example “Send to” still doesn’t work.

You can download the 4.6.2 build at https://www.newsblur.com/ios/download. Let me know how that works out. It won’t get approved for another week I’m afraid, due to the holidays. So your best bet would be to download that build.

I gave it a try and the crashes in Original View seem to be gone. “Send to…” is still not functional though.

Same thing here, crashes when trying to ‘Send To’ using the mail icon, and the ‘Send To’ does not work on iPad. I’m on version 4.6.2 and iOS 8.1.2 on my iPad Air and iPhone 6.