iOS app v2.0 RC 1 Bug: Instapaper still not working

same bug as in beta: InstaPaper credentials still not accepted (with silent failure).


The same problem on iPad 1, iOS 5.1.1 and Pocket.

Tested it out and it works fine for me. Not only that, but it pops up a dialog confirming your account before it saves the story.


I think I figured out the problem (after deleting and reinstalling the iOS app didn’t help). I think there’s a problem with the way you handle the password string.

My password has non-alphanumeric chars (for security) that seem to cause the problem. The percent sign (%) in particular seems to cause the NewsBlur app to barf on the string.

At least, it’s definitely true that deliberately putting in the *wrong* password, if it contains %, doesn’t even generate the proper failure error message. Because my password contains % (and other non-alphanumeric chars), it seems likely that the app’s inability to log me in is because it is mangling the string in some inappropriate way.

Can you check for this? Is it some subtle misuse of sprintf()?



Not doing any special handling. Here’s the source for Instapaper:… and the source for the abstract read later service class:….

I’m guessing that your switch/case in handleStatusCode is exiting via default, and maybe the actual error code is being dropped there.

At any rate, I changed my password to be the same but without the %, which fixed my particular user experience: now the 2.0 app works with InstaPaper just as well as 1.0 used to with my original password.

One other thought, looking at your code. Could it be as simple as the needing to escape any percent chars in loginWithUsername’s urlString?

I’m not an iOS programmer, but from it looks like the url should be escaped with stringByAddingPercentEscapesUsingEncoding:NSUTF8StringEncoding.


I can confirm this issue. With an Instapaper password that included } and @, I consistently got the silent error; after updating my Instapaper password to only include alpha characters and dashes, worked fine.

I’m not an iOS programmer either, so the source code means virtually nothing to me, but I can confirm that I had problems logging in to Instapaper, but when I changed my password so that it didn’t contain non-alpha-numeric characters the problem went away. For me it wasn’t a “silent” error, the NewsBlur app would actually tell me that it failed to log in.