iOS app crash in safari view

#1

It doesn’t crash a ton (a few times a week?) but when it does it is almost always scrolling through my Vinyl Subreddit feed. https://www.reddit.com/r/VinylReleases/.rss is the link. It’s a fairly active feed - often 50-100 entries a day. I go in once or twice a day to scroll through the titles and then mark all as read. If NewsBlur is going to crash, that’s when it happens - scrolling through the entries.

iPhone 12 Pro Max (though this happened on my iPhone 7 as well)
iOS 14.2 (though this has been happening for a long time)
Dark mode (if that matters)

#2

And I just found a reproducible crash every time. Different feed, for Casey Liss’s site “Liss is More”, loading up his latest post and clicking on the link with the text “single serving site”. Has now crashed four times in a row. http://www.caseyliss.com/2020/11/10/on-apples-pisspoor-documentation

#3

Ok I’m at a loss because I subscribed to that site, opened the story, and tapped the link and it opened fine. Do you have any Safari content blockers installed?

#4

I do! And I tracked it down to 1Blocker. Should I file a bug with them as well? Is protecting against (apparently) “bad” content blockers something that NewsBlur can do? Or is it out of NewsBlur’s hands? If it matters, I use the built-in browser to NewsBlur, I don’t have it launch into Safari.

#5

Yeah you should let 1Blocker know. That view is handled by iOS, which means it basically native Safari (that’s why it doesn’t retain any of the color of the NewsBlur app). Now why 1Blocker is causing the crash who knows, but I installed 1Blocker and tried it out and it still worked for me. If it had crashed I would at least have a traceback, but it worked fine.

#6

Is there a TestFlight of Newsblur that I can join to get you the trace back off my phone?

#7

And after playing around with it a bit, it stopped crashing for me as well, which (wild guess) happened because the view was able to grab everything it needed from a local cache and stopped triggering the bug which only happened on some network call. I may try some rebooting and whatnot to clear caches and see if I can get it to reproduce again.

#8

Yup, it’s crashing for me again. I bet if you turn on 1Blocker and check again it crashes for you.