Intelligence trainer stopped working for individual stories

When I right click on an item and select “intelligence trainer”, nothing happens. It works for entire feeds though. I’ve tried Chrome and Safari.



Confirmed here. Firefox 26 and 27b1, amd64 Linux.

Same here with Firefox 24 on Windows. If I open an item, the “train this story” button still works, though.

Ditto. Firefox 26 on Windows.

Same here. Chrome 32 beta on Windows as well as both iOS & Android mobile clients.

Same problem. Firefox 25.0 and also on Internet Explorer 9 using Windows 7 64-bit. Tried it in both browsers with all add-ons disabled.

So I have no idea how this broke. I went in to fix it and the entire event handler went missing. I added it and all is well. But … how on earth did that happen, I’m not sure. And how long it’s been broken is a mystery.

Looking through my diff history, it seems I broke it on Dec 5th when I added the new story mark as read in a direction items. So that explains it. Anyway, all fixed now.

@Samuel: Thanks for the fix; it is working again for me!