Intelligence Trainer not retrieving article data

The “Train this Story”/“Intelligence Trainer” seems not to load any article information, sporradically. After multiple clicking on the “Train this Story” button (5 to 20 times) it manages to load the tags, authors etc… information. Tried this both at work & at home in multiple browsers, on multiple ISPs/different ADSL/Cable modem lines and on different feeds. I also tried waiting for the Intelligence Trainer to retrieve the article info for a few minutes to no avail. (Screenshot below)

This is slowing down my workflow considerably. Please fix :frowning:


The problem seems solved in the last day or two. I’ll give it a few more days to be sure. Whoever did anything about it Thank You.

and it’s happening again at a reduced level. Ie: Before it was happening much often then it is now but the problem seems to be still not totally solved…

Is this related to the server load, maybe ?

same happens here, you need to run it few times to see full windows (or you can scroll), definately needs fixing - happens in firefox :wink:

I’m having this problem nearly constantly in Firefox. About one in 10 times it will work correctly immediately, but most of the time I have to try it between 5 and 15 times in order to even get the tiny half-line slit that I can scroll. Most of the time not even this much will load.

Yes, it’s still happening and I’ve given up that the author or somebody from support (if there is anybody else except the author) will reply or fix. Not even a single reply in one month even to say that they are looking into it.

Come my payment date I will not renew my subscription due to this but for now I’m stuck with it :frowning: … This was the reason I chose Newsblur but the function is not working correctly and losing me more time then it saves me!

If anybody knows of another trainable online rss reader site please let me know on this thread. I know that this will probably be on the radar for a few of the recent rss reader startups once they settle their base code. *fingers crossed*

Dejjem, I wouldn’t assume the worst. I just haven’t seen this support thread because it’s from a month ago. Problems need to be bumped, and usually are if they affect enough people. Looks like this is a FF bug. I’ll try to fix it, but these things are tough to figure out since they work in other browsers.

Also, try resizing your window when this happens. That forces modal dialogs to realign themselves and could possibly force them to redraw.

I can’t reproduce this at all. Tell me exactly how it’s coming up. Do you have a short or tall browser window? Are you loading it by right-clicking on a feed and opening Intelligence Trainer?

The method of opening (either clicking on the arrow next to the feed, or clicking the button at the bottom right of the post) doesn’t seem to make any difference for me.

I normally run Firefox maximized, on a 1920x1080 desktop. Resizing the window makes the Intelligence Trainer popup squish vertically even more, so that not even the whole header is visible.

I’m going to disable all my add-ons and do some testing to see if one of them is possibly screwing with it (Ghostery in particular sometimes seems to cause strange problems that it really shouldn’t).

With all add-ons disabled, I’m still having this problem with Firefox 22.0. Actually, mine is a little worse than the image above, since in that window you can still actually see something. Most of the time, I’m not getting anything at all.

Samuel, thanks for replying didn’t realize that you were waiting for bumps as I assumed you or somebody else went through the reported problem threads on this site.

My resolution is 1920x1200 & 1920x1080 on another computer. On both it happens. My experience is exactly as khelton as in it doesn’t matter which if I click next to the feed or the button on the bottom of the feed.

I had actually managed to replicate this on other browsers (it was either IE or Chrome I can’t remember which as it was a month ago) and both from my home ADSL line and from my workplace’s cable internet line however I just tried for a few minutes and it always worked in chrome. If this is just a firefox issue for me personally it’s not much of an issue as I’ll train it in chrome and then switch to FF to use the actual feeds. The problem was that I couldn’t manage to train it at all and I have several spammy/high volume feeds.

I also have ghostery installed but I just did some testing with it disabled and I still have the same issue.

If I could hazard a guess I would say that the internet speed or load on the newsblur servers is the factor if it happens or not… From what I’ve seen there’s a patch of time where it always works (see my post above where I thought that you had solved it) and then another where several posts training do not workfor a stretch of time. I also have multiple negative taggings, don’t know if this may affect combined with the service speed.

I’ve been testing on this in the last few minutes ->…

The above post worked a few times in FF but mostly it didn’t.

khelton that’s probably because my screenshot is @ 1920x1200 (16:10).

Good news, I think I figured it out. Just deployed a fix and now it works great for me on FF. Let me know if it works for you.

I doubt it has anything to do with my screen resolution, because sometimes I get that narrow slit that I can read about half a line through, and other times I don’t (and once in about 20 tries, it actually loads like it’s supposed to), without changing the window size.

Definitely check again. I just pushed an update through that should permanently fix it for everybody.

It appears to be working, with all add-ons disabled, for all the 4 or 5 posts I tried. With my add-ons it’s still a crapshoot, but that’s my problem. :wink:

I’m sorry to say that this problem is still not solved for me. I’m on FF 22 too and I disabled all my addons (didn’t have much addons, just the usual 4-5 ones) but at least it does seem to be FF only. I’ve been mashing the intelligence trainer like mad in chrome and it always worked.

Also I just noticed that it is not working in FF only at folder level (ie: when I have multiple feeds in a folder and I’m viewing the whole folder). At feed level it seems OK. Not sure if it was like that before also…

khelton, when you tried it, did you browse at the feed level or at the folder level (with multiple feeds in the folder)?

Yes, I was browsing by folders, and I swear it was working perfectly for me with add-ons disabled. I’ve tried it again just now (with add-ons enabled) and it works on the 2nd or 3rd try pretty consistently, but still hardly ever works the first time, for some reason.

Good news x2, I fixed it for FF for story view, feed view, and trainer view. You should notice a remarkable improvement.