How to connect the Twitter and where to see the tweets of following friends of Twitter in newsblur

I have connected the Twitter in newsblur, but I can’t found where I can see the tweets of my twitter friends.

1 Like

I can’t found where I can see the tweets of my twitter friends in Newsblur. Could you kindly help me to solve this problem?

You also have to subscribe to the ones you want to see. Subscribe to for each user you want to follow in Newsblur. I think it only shows public tweets, so if your friends are set to private, you can’t see their private tweets. I’m not 100% sure on that, but Twitter’s APIs are usually the limit there.

When I try subscribing, I get the spinning wheel on iOS?

Been trying for over a week.

Running iOS app latest version.

Any help would be greatly appreciated,

Try subscribing on the web and see if it gives an error or works differently.

Your Twitter connection isn’t setup. Go to Manage - Friends and reconnect Twitter.

I get this error on the web. I do not know how to manage friends and reconnect Twitter?

Any help would be appreciated,

Hi, I tried the Twitter connect as well and got the spinning wheel.  The javascript console (chrome under Linux) shows: twitter_connect:60 Uncaught SecurityError: Blocked a frame with origin ""; from accessing a frame with origin "".  The frame requesting access has a protocol of “http”, the frame being accessed has a protocol of “https”. Protocols must match.

1 Like

Getting the same “Twitter connection isn’t setup” error as harvisonjames above. Anybody found a way around it?

I’m guessing here, but it’s worked for me on Chrome (though I’m on Windows). The thing I’ll point out though is that I’m on Based upon that error, are you?

Ok, it seems like there’s a few issues here. For one, the iOS app is not doing a good job of letting you know the error. That’s odd, because it should. Just checked and yeah, the iOS app is no longer showing any errors whatsoever in the subscribe popover. I’ll get that fixed.

Next, that console error when you try to authenticate means you should switch from https to http. If you do not want to, try switching browsers. It’s a cross-protocol security limitation in some browsers. You can enable it, but that’s a bit of hunting to find the setting.

So what I did was change the OAuth callback URL to https instead. So try again and it should work now without having to change browsers.