How can you set newsblur up to forward a link from using your gmail account?

I would like to be able to forward a link using my gmail so that I don’t have to type in the email address manually. And open in email client does not work because I have outlook installed on my computer, which I don’t use for gmail. I have a plug in installed that will redirect mailto: links to gmail but it does not work when using “open in mail client” function. I am really happy with newsblur since google reader has stopped but I really want this feature to work.

1 Like

You’ll have to set something up on your machine that takes mailto links and opens gmail. That has to exist by now, since many folks have used gmail on the web for nearly a decade now.

I have tried “Mailto: for Gmail” and “Mailto:” plugins in chrome both of them use outlook when clicked in newsblur but they work fine when I click a mailto: link in another part of the browser like a webpage.

Craigslist has some sort of thing where it lets you “reply using webmail”, and you can choose services. I don’t know if the code is obfuscated or whatever, but that might be what you are looking for.

just look at any old add and hit the reply button.

Could those be added as options in the UI, in addition to “E-Mail”?

There should be a just an email link on the page like google reader so you can email a link without haveing to go up to the tiny pull down menu and selecting email then opening a second window then opening a client. Can that be implemented? not necessarily embedding gmail in your GUI but just a mailto: on the main page.

They would clutter up the page for a less often used feature. There’s a reason it’s in the menu. As for the other options, there really should be a non-NewsBlur solution. It’s not up to NewsBlur to figure out the email client. It just hands your browser an email. Certainly somebody’s built this. In fact, here’s an article that describes how to set Gmail as the default email provider in Chrome, Safari, and Firefox:…

I’m Sorry I’m not trying to be difficult but I have tried that and tried several different plugins and they all work for mailto: links. The problem is that they dont work for newsblur because it does not appear to be a mailto: link. I have tried using the mailto: for other sites and it opens up in gmail no problem. The problem is in how newsblur opens the link because it opens outlook every time and not gmail. I have tried this several times with multiple plugins and they all work for mailto: links on every site except for newsblur.

Joseph, are you using Internet Explorer? I ask because both Chrome and Firefox make it easy to designate Gmail as a mailto handler without plugins (it’s simply in the Options). And NewsBlur’s “open in email client” works just fine for me in Chrome and Firefox without plugins.

For IE, the Gmail Notifier is suggested; this should persuade IE to use Gmail.

No I am using chrome

Well then I’m really confused; Chrome should use Gmail by default.

Try this - go to Settings and use the search box in the upper right to search for mailto. That should bring up Privacy with a button for Content Settings. Click that and scroll down in the pop-up to Manage Handlers - click that and you should get another pop-up for Protocol handlers (Type and Site) where mailto should be listed under Type and Gmail should be listed under Site (if not, select it in the dropdown). Click Done a couple of times and you should be set.

If that doesn’t work, it would seem your default has to be reset in Windows itself, which is another kettle of fish entirely.

Ok so I tried that and this may be something, under protocol handlers there is nothing there. How do you add something to the window there is only a “done” as an option.

Could we get a few extra sharing services added for webmail, or the option of using custom URL schemes that put tokens in a URL scheme?

Google Reader did that, and Feedbin does it. I did it on my Fever install:…

looking again at what craigslist does, where ${token} represents information about the article:




OK, here’s the solution I found in Google’s message boards (tried this myself and it worked for me; I first removed Gmail as a handler in Chrome and then re-enabled it with this).

With Chrome open to your Gmail inbox and no other tabs open, copy and paste this into your address bar:


Note Chrome will probably cut off the javascript: at the beginning, so you’ll need to re-type it. Hit enter, and Chrome will pop up a notification bar asking if you want to use Gmail for mailto links. Click Yes and you’re done. If you go back into Settings, you’ll see Gmail in your Protocol handlers and the NewsBlur email link should open a new window with a Gmail compose pre-filled.

YES!! This did it. Thank you!

Solution found by Ed D

You’re welcome! I was just about to edit because it looks like the board software cut off that address; in case there’s a problem, the whole thing is:

(“mailto”,“ mailto&url=%s”,“Gmail”)

(Eliminate the return after ProtocolHandler and the space after extsrc=)

All my mailto link all fwd to gmail window except for newsblur site! anyone else have an issue? with chrome Build Beta 30.1599 ?

Got it working, in the new versions of Chrome, the way handler prompts are used is different as you get a arrow sign once gmail is open to confirm using them. (Java scripts do not work in the new versions)…