Feed from shutupandsitdown.com/feed/ is 403'ing

#1

Hi,

I know there has been problems with this feed in a long time since they enabled some kind of DDOS protection on their site. But instead of ignoring the problem any longer, I contacted the owner of the site which responded with:

We turned off hot-link protection, is it working now?

Which indeed changed the error in newsblur in some way since I don’t get “HTTP Error (403)” immediately but instead get “There was a problem fetching the feed from this URL.”. If I check the network traffic from newsblur.com with Firefox I can also see that there are some kind of parsing going on since the call returns some data which seems to come from the feed.

But in the end the result are still that newsblur marks the retry as “2020-02-12 11:27:01 HTTP Error (403)”.

I don’t really know what happens here but I guess there could be some parsing issue or maybe there are still connection issues. It is difficult to know without access the newsblur’s server logs.

Therefore, I hope to get some help to clear things up by creating this issue here on the forums.

#2

This continues to be a problem, and the feedburner link in the other post doesn’t work either. Can a dev weigh in please?

#3

Hi, a 403 is a Forbidden error. That means that NewsBlur isn’t even receiving the feed from their server. Their server is denying NewsBlur. Typically this is due to an automated enforcement mechanism on the publisher’s end that denied “robot-like” behavior, which in this case is probably true as NewsBlur is fetching that feed every few minutes. NewsBlur won’t put a strain on their resources, since once every few minutes is nothing, but some administrators prevent useful robots like NewsBlur.

I suggest contacting them and letting them know that they are 403’ing our feed fetchers.

#4

Thanks for you response. I have forwarded your answer to the site owner of shutupandsitdown.com. Let’s hope we can get this problem fixed! :slight_smile: