Feed fails to load. Bug?


#1

I’m having trouble with this specific rss feed:

http://hnapp.com/rss?q=author%3Aanigbrowl

I checked at the W3C feed validation site and it shows it’s a valid Atom feed.
Other feeds from the same site (hnapp.com) with different author queries work fine.
e.g http://hnapp.com/?q=author%3Aconesus

Could you check please?
Thanks!


#2

Looks good to me: http://www.newsblur.com/site/7125259/authoranigbrowl-8211-hnapp


#3

Thank you. I was able to subscribe through your link, but before doing that I tried again and got the error: “This address does not point to an RSS feed or a website with an RSS feed”
error
This snip is from a few minutes ago, so you might be able to see it in your logs.

Strange. I wouldn’t expect this to be a problem on my side (all other author queries worked fine, you can check my feeds under the “AB HN” folder) but it was reproducible (tried several times when I set up the other feeds and today.)
In any case, this solves my issue for now, but let me know if you want me to try anything to help you debug.
Thanks!


#4

I bet it’s some intermittent issue on their side. Probably a 500 error on their side, as it looks like they’re doing in series requests, which means it’s probably timing out. Once it’s in NewsBlur, NB will take care of it even if the feed goes haywire every so often.


#5

Makes sense, thanks for looking into it.