Expired certificate

#1

Hi @samuelclay,

The let’s encrypt certificate for NewsBlur.com has expired today.

Probably fixed quickly I assume that the chron script is not working

Dennis

#2

Fixed! Sorry about letting that happen, I didn’t run the SSL cert script because the date I had was in November. Looks like it was the wrong date.

#3

No problem, are you using certbot to renew, you can use it once a day. It will only renew if the certificate will expire in 30 days see https://community.letsencrypt.org/t/renew-letsencrypt-certificate/34677

#4

Seems like this may still be an issue for the image proxy cert

image

#5

@samuelclay I’m still seeing an issue with the cert. Curl’ing from an ubuntu 20.04 host fails with a certificate validation error for https://www.newsblur.com.

It looks like www.newsblur.com is not serving the intermediate certificate(s) in the certificate chain so things that don’t preload all the lets encrypt intermediate certificates will still fail.

#6

What was the curl command you used to test the certificate?

I also just pushed out a revised certificate with the intermediate certs. Let me know if that fixes the issue.

#7

Yup that fixed it.

The command was simply: curl https://www.newsblur.com.

#8

Still seeing issues with the image proxy cert: https://www.ssllabs.com/ssltest/analyze.html?d=imageproxy.newsblur.com&latest