Evernote blog gets no new feeds after 3/2/2013.

Works ok in google reader.


Same here for this feed: http://www.materiel.net/rss/baisse.rss
Many entries are outdated, or does not appear.

Seems you were subscribed to the Evernote podcast feed. Checking the address, it was /feed/podcast/. I switched it to /feed/, and now the stories are there. However, the latest story is from the 2nd. See the feed: http://blog.evernote.com/feed/

Holy cow, it seems if you go to http://blog.evernote.com/feed/ it only shows entries up to the 2nd, but if you go to http://blog.evernote.com/feed/?_=12345 it shows the newest entries. Cache busting it seems is necessary for this blog. Iā€™m going to implement cache busting for forced feeds, as well as randomly (maybe every 100 fetches?).

And done. Evernote should now work well.

Thanks - works now.

This feed http://pongsocket.com/tweetnest/feed only shows the first entry in NewsBlur too. Just tried insta-fetch, no change.

Or maybe not. Three new Evernote items in Google Reader none in Newsblur.