Delete Site usually fails in iOS app

When I try to delete a site from my iPad (using the latest version of the app), it only works about 1/4 of the time; the rest of the time the site is not deleted.  Trying again might occasionally work, say in 1/10 of the cases.

1 Like

How many sites are you subscribed to? How long does a pull to refresh take to go from On its way to Counting is difficult?

Hi Samuel,

Thanks for the quick reply.

I have 248 sites.  I usually read my feeds once a day and it almost never takes more than about 20 seconds to refresh NewsBlur on my iPad.

To me it looks like Delete Site simply times out and returns to the main screen without doing anything.

The problem has been around for at least 6 months.

Garland

If the deletion request hits the server, the feed is deleted. Next time it happens, try pulling to refresh and seeing if the feed is gone.

I tried this and it didn’t work.  Twice I deleted the site then pulled down, the site was still there.  I exited the app and opened it again, the site was still there.  Then twice I deleted the site then pulled down, the site was still there.  

FYI, here are 4 sites that I can’t delete from my iPad.  I tried several times, then bounced the app and tried again.  

I just updated the app to NewsBlur iOS version 5.0.3, bounced it, and tried again.  No change.

NNTR

Garland

Are you able to delete them from the web?

Yes, that always works.

FYI, I found another 3 sites that I couldn’t delete from the iOS iPad app.  

As as test I uninstalled and reinstalled the app.  That didn’t help.

NNTR

Garland

What are the site names? I can login and find the bug. Just make sure they aren’t deleted yet.

There’s a site in my account now that I can’t delete from my iPad; its name is:

Hussman Funds - Investing for long-term returns while managing risk - Home page

Garland

After many months…

Delete This Site still fails ~95% of the time on my iPad 2.

And Move To Another Folder is still broken: it doesn’t move the site, rather it makes the site also appear in another folder, in addition to the one it’s already in.

It would be great to have these fixed.

Thanks,
Garland

I wonder what’s going on with your account, because I just tested it and it’s working well. I can login to your account and test. Do you have a folder I can move around or delete?

Alternatively, do you have a site you’d like me to delete? I don’t see the original feed you wanted to delete.

Thanks, Samuel.  I just tried removing the app from my iPad and reinstalling it, and I’m still unable to delete sites.  Here are 3 that I want to delete and can’t from my iPad 2. (Note that I am able to delete sites from the web client.)

  1. Google Alert - “Exercise Coastal Response”
  2. Google Alert - “identity management” “identity and access management” “identity & access management”
  3. Talking Identity | Nishant Kaushik’s Look at the World of Identity Management

Garland

Ah-ha, figured it out. Turns out you have hyphens in your folder name. Through a quirk of engineering (read: my mistake) hyphens caused your feed to not get deleted. I’ve fixed that on the server side and you should now be able to delete feeds. I deleted the Exercise Coastal Response feed for you.

And thank you for bringing this ticket up again. Six months is a long time, but it worked out.

Wow, that’s great!  I was able to delete the two other folders.  Thanks!

Garland