contents of feed not displaying

i subscribed to and the newsblur web app appeared to get stuck at the “counting is hard” part. no stories were displaying in the right column either. i’ve seen this happen before, so i re-loaded the whole site again. no stories appear; the feed seemingly has no content.

i did some troubleshooting and here’s a few notable things about the feed:

* newsblur reports a status of 200:…

* is served from amazon s3/cloudfront which does not appear to honor the lack of the Accept-Encoding header. in other words, it always serves gzipped content.

* the w3c feed validator is choking on validating the URL at the SSL negotiation part:…

* output of curl -Iv looks like this:…

* pasting the actual Atom XML into the w3c validator form yields a bunch of seemingly minor errors as seen here:…

so my two leads are something with SSLv3 and gzipping (server forces response even though client didn’t request it).

thanks for looking into it!

1 Like

Thanks for the heads-up, Justin. I’ve fixed the Atom validation errors (more thanks for pointing those out) and have disabled gzipping in case that was causing the problem. The SSLv3 errors seem to just be a current problem with the validator.

andrew, thanks for the quick feed fix and config change. unfortunately, things are still not working. i tried refetching the feed in newsblur after your gzipping change and newsblur still reports the response as a 200 without displaying any stories.

that’s a good find re: the w3c validator problem (i didn’t bother digging deeper last night, it was late). like the validator, newsblur is a python app. the linked github issue from the google groups link you cited was enlightening: SNI is emerging as the likely issue.

if it truly is an the SSL level, then newsblur appears to be misrepresenting the fetch/parse status. :-/

facts so far:

interestingly, looking at the history for requirements.txt, i see that back in may of this year SNI support was merged in, yanked, reverted, and then reapplied, generally by just updating the dependencies. see issue #534 and PR #536 for discussion.

last thought: mnot mentions in his blog that “Python 2 should be getting it [SNI] in the next few weeks, when 2.7.7 is released”. if that’s the magic, i wonder what version of python samuel is running on the servers. i just see python-dev listed in his it seems that he upgraded the servers to 14.10 LTS back in late september. however 14.10 LTS is seemingly still locked on python 2.7.5.

if we are to trust the above sources and follow them to their logical conclusion, it would seem that newsblur is powered by a slightly-out-of-date python version that doesn’t support SNI. that’s my wager, at least.


this is devolving into technical territory and dependency hell. not sure the SNI stuff (if that indeed is the problem) is best represented here or as a github issue.

if anything, what i hope to get solved here is that whatever error is happening deep inside of the app gets represented a bit more accurately or actionable in the UI. i dunno, something like “unexpected feed error: report bug.”? anything is better than what’s happening right now. better ideas are of course welcomed. :wink:

btw, hats off to samuel for open-sourcing such a great app. tracing source code and commits is much more productive than clicking on a black box’s buttons and hoping for it to work.

(sidenote: getsatisfaction really needs markdown and preview support. writing html in comments is so lame. :-/)