Cannot Add Any New YouTube Feeds

For the past several hours I have not been able to add any new YouTube feeds. Anyone else?

I don’t see any other reports on here yet so I wanted to make the issue known or find out if I’m the only one. I’ve tried on the android app and the web. Thanks!

1 Like

Got an example feed?

All of them that I’ve tried so far have failed, so I don’t think it’s any particular channel. It’s possible the issue is on YouTube’s side, but when I go to the feed url directly it seems to display as expected.

For example,

I’ve tried the RSS Feed directly too.

When trying to add the channel by channel url, which is what I always do, NewsBlur throws an error back. When I add the feed URL directly it will add a feed named “untitled” and will not populate any videos.

I thought maybe it was related to the server change because last night was the first time I’ve tried to add a YouTube feed for a few days.


1 Like

The same problem.

1 Like

Hopefully this is resolved soon. 80% of what I use NewsBlur for is YouTube feeds. Yes, a bit of an odd use case but that’s why I have a Premium Archive account.


This is an application problem, because everything works fine in other rss readers.

1 Like

Also, the YouTube feeds that I already have added are working fine. I just can’t add any new feeds.

And my old ones do not give out errors, but they are not updated.

Ok I see the issue. I’ll have to rewrite the youtube fetcher which might take me a couple days. This is my top priority, so I’ll get to it soon.


You’re the best!

This has been working good since your fix, but I did run into an issue today that is giving me the [untitled] error again. It’s when trying to add this channel

I thought maybe it’s because of the dash in the channel name. I tried replacing the - with the HTML code but that didn’t work. Any ideas?

One other side note is when adding a channel it used to copy the channel name with capitalization and now it’s always lowercase. I manually rename feeds anyway so not a big deal but thought I’d let you know.

1 Like

Same here: Cannot add youtube channel - #11 by Hg201

1 Like

Can we get a confirmation that this is being worked on? Not being able to add some YouTube channels, even using the official YouTube RSS URLs, is quite limiting. I just had my Archive Account renew for the year and have been mostly really happy with the service, but I would like to be able to fully use it. Thanks!

Ok, added support for hyphens in youtube usernames.

I’m sorry, but does this mean that the problem with YouTube has been fixed?
It still doesn’t work for me.


1 Like

Weird. I see the screenshot and it’s working for you, but I’ve tried on the Android app and on the web and I still get the [Untitled] error. There are other feeds without a hyphen that cannot be added as well. Like described here Cannot add youtube channel - #11 by Hg201

This is the feed:


Yes, it works on your server.
I mean my server. What should I do with my installation to make it work too?

I have updated the files from the repository that have been changed. Then I launched the make nb. But that didn’t fix the situation.

Maybe it is necessary to clone the repository completely?