Can’t expand public comments on 2nd & following articles

I’ve been having an intermittent problem for several months where nothing happens when I click to expand the public comments in an article. I finally figured out how to reproduce it today. (You need “Only show comments from friends” for this.)

It seems to affect the 2nd and subsequent articles I open. For example, just picking randomly from the global shared stories now (…), if I click on the comments “+” for this article:…

I can expand the comments, but if I then click on the “+” for this one:…

nothing happens.

This happens with multiple browsers (Safari, Chrome, Firefox) on OS X.

1 Like

I can’t reproduce it. What’s your username?


Were you able to reproduce this?

I tried tracing into what happens on a click a bit with the Web Inspector, but there isn’t a straightforward event handler; there’s lots of JavaScript in there (which also seems to be obfuscated/compressed) and it’s a bit much for my Web debugging skills.

Short of installing the NewsBlur server locally, is there anything else I can do to help?

If you want to try using an uncompressed JS, head to

Thanks. So, I found out the function that’s supposed to be getting called is load_public_story_comments. I put a breakpoint in there and it only triggers on the first story:

NEWSBLUR.Views.StoryCommentsView.Backbone.View.extend.load_public_story_comments (story_comments_view.js:164)
jQuery.event.dispatch (jquery-2.0.3.js:4676)
jQuery.event.add.elemData.handle (jquery-2.0.3.js:4360)

When I click on the “+” for the 2nd story, I end up here instead:

NEWSBLUR.Views.StoryDetailView.Backbone.View.extend.mark_read (story_detail_view.js:498)
jQuery.event.dispatch (jquery-2.0.3.js:4676)
jQuery.event.add.elemData.handle (jquery-2.0.3.js:4360)

Hope that helps.

Hmm, is the story unread? Do you use a setting that keeps stories unread for a bit? Anyway, I logged into your account and public comments were loading just fine. Can you offer the exact routine you went through from load?

Yes, the story was unread; I only had unread stories visible. “Mark a story as read” is set to “Immediately”.

Here’s a video. I only interacted with NewsBlur with the mouse in it.…

Thanks for your immense help! Tracked down the bug and fixed it. Now deployed.

Works! Thanks so much.