Audio podcast issue

I can’t seem to play audio podcasts properly in NewsBlur feed view. For example:…

There is a big rectangle with an X in it which, when clicked on, gives one of those spinny timer thingies and sometimes eventually starts playing audio a few minutes later, and sometimes never plays it. There are no play controls, and when it does play it acts more like its downloading the whole file in the background before playing it, rather than streaming it immediately.

Thanks for any help.


Any suggestions or thoughts on this? I’m using Firefox on Mac (newest versions of both).


Hmm, works for me in Safari and Firefox. What browser/OS are you using?

I never actually tested the audio tag in IE. I’m wondering if that’s where it doesn’t work. It’s been an HTML standard for years, so it should work by now in IE, but that may not even be your browser. (Based on the font rendering, it looks like it may not be IE, or in fact it may be some super recent version of IE that has better font rendering but still no audio tag support.)

I’m using the most recent version of Firefox on the most recent version of Mac OS X.

Same problem, using FF 9.0.1 with Windows 7.

Firefox doesn’t support playback of MP3 audio via the audio tag:…

The example podcast only has a MP3 source element, with no supported alternate source elements, so Firefox won’t be able to play it via the audio tag (flash should work).

Not sure why it’s working on Samuel’s version, however. I’m using Firefox 5.0.1 on Windows 7, and I have the same issue.

I won’t pretend to know anything about browsers and standards, however there is definitely a way to do this properly in Firefox - because Google Reader does it. There are many other reasons why I switched to NewsBlur over Reader, but this is something that Google got right. Also, Samuel’s response indicated this should work (refer to his screenshot). And here’s what it looks like in Reader:

I’ll try to get to this in the next week or so. I’d like to get it working in Firefox without having to support even more Flash.

Samuel, just an idea, but I thought of a hack which would avoid flash: Replace the audio tag with a placeholder div, which when clicked swaps itself with an iframe which has the mp3 URL as it’s src.

This would make the browser play it with whatever mp3 plugin is used to handle direct MP3 links (probably quicktime), and would display whatever controls the mp3 plugin would normally display for a direct mp3 link. With some styling it could look pretty seamless.

So how’s this issue coming along?

Based on the answer to this StackOverflow answer, Firefox does not support audio playback of mp3s:…

So unless the original feed author has provided multiple sources (ogg, mp3, anything else), you’re out of luck with native elements.

What I’m going to do is turn it into a hidden container that you have to enable, in order to speed up those feeds, and then also find some Flash-based solution if the native html5 audio tag doesn’t work. Not sure when I can get to this, but I hope for Monday.

Thanks for the update.

Good news! Pushed out a pretty big update to make this cross-browser and load somewhat faster. It no longer preloads audio, and the new controls are much nicer.

See the commit:…

Let me know if it really is faster and if it works better for you, especially in Firefox, where it never worked until today.

Works great! Thank you!