Android: Reading actions won't sync

app version: 4.8.0 android version: 6.0.1 (MMB29K.G920VVRU4CPC2) device: samsung SM-G920V (universal7420) sqlite version: username: mokelly memory: normal speed: 0 feeds in conn:0 read:0 parse:0 store:0 pending actions: pre:209 post:0 premium: unknown prefetch: yes keepread: no

I went on vacation for a week, with sporadic internet, and now my Android NewsBlur app seems to be permanently stuck “Catching up 209 reading actions”.  It’s been stuck this way for 3 days now.  The app won’t fetch new stories or sync anything else either.

I’ve tried force-closing the app, rebooting my phone, and cycling through different kinds of internet connectivity.  The “Refresh” command is unresponsive, as is the “drag down to refresh” gesture.  Reading additional cached stories does increase the number of reading actions remaining.

The reading actions include a large number of “share” requests, so I’d rather not clear the cache or reinstall the app if that can be avoided.  Anything else I should try that might preserve my pending actions?  Thanks!

1 Like

The app definitely tries to play catch-up on anything you did while offline before doing another sync.  If it is having any trouble doing so, it will keep trying periodically.  Those actions won’t be lost unless you clear app data, log out, or upgrade the app.

I have personally tested having up to 50-75 actions queued up, including reading, shares, and saves and it worked okay, but it sounds like one of yours must be stuck for some reason. The only time catch-up will get stuck is if the NewsBlur server cannot be reached or if it is returning an error.  I will reach out to Sam to see if there is some reason the latter could be happening.

Nothing in the logs or exception trackers showing issues. If the requests are coming in, they seem to be checking out OK. Do you know which requests would be failing? Have a date and time? I see many Chrome and Android requests, including story shares, coming through successfully. 

Got an example story title that I can search for?

Here’s an example article that is read on my Android but not on the web interface: (“Backpacking Quilt Adoption Rate – Survey Results”).

The app doesn’t report any errors or lack of network connection, it just animates forever on “Catching up 212 reading actions”.  (I’m able to read cached stories, but not fetch new ones.)  So, I suspect the app isn’t actually making any network requests.

Network requests in other apps are working fine.  The “Fetching text” functionality in the NewsBlur app is also broken (sits forever without reporting an error), which again makes me think the app is stuck in a state where it can’t actually make network requests.

It just occurred to me – this problem may have started soon after a NewsBlur app crash a few days ago.  I chose “Send report” but couldn’t tell if the report went through.  Did you get it?

I’ll try clearing the app data in a few hours, just to move on, unless you have more questions or suggestions for unblocking this.  Thanks!

I see at least one crash from an S6 with the same model number as yours, when the app was refused access by the Operating System to open any more network connections.  Unfortunately, we didn’t get any more info than that.  Are you running any sort of VPN, adblocker, task killer, battery saver, or memory saver?

If the app can’t get to the NewsBlur servers to catch up your reading actions, it will delay/defer any attempts to sync, including fetching text, etc.  In order to make sure the app doesn’t hammer your battery, if it can’t reach to the server, it gives up trying to talk to it for a period of time.

Any and all info on what settings you have configured (especially custom ones or one related to the battery-saving features in Android 6) might help us track things down.

I often use the Galaxy S6 “Power Saving Mode”, and the phone was in Airplane Mode (with Wifi sometimes toggled on) for most of the one-week trip.  During the 3 days the app was stuck “Catching up”, toggling these different modes, or trying Wifi vs cellular data, didn’t unstick syncing.  I don’t use any of the other things you mentioned as possible culprits.

Something possibly related: about once a week for several months or more, “Fetching text” has stopped working for 100% of articles in the Android app.  Once that happened, the only way to restore “Fetching text” functionality was to force-kill the app.  (This seemed too minor a bug to report.)

Late last night, I finally cleared the app cache (which didn’t solve the problem) and then the app data --which did immediately solve the problem.  So, the problem seems likely to have been that some combination of irregular internet access and flaky hotel wifi put the app in a permanently hung syncing state.  Might not be worth more time spent trying to diagnose, but I’m glad to answer any more questions you have.  Thanks for looking into it! 

Thanks for the awesome info!  I will do some intensive testing with both Power Saving Mode and being offline.  I can certainly imagine the combo might make things interesting for an app that is patiently trying to sync a bunch of stuff. 

> Something possibly related: about once a week for several months or more, “Fetching text” has stopped working

Hmm, this feature has always given us a bit of a headache, since the text fetch takes a bit longer than most operations and some phones get kill-happy if they think an operation is stuck.  I’ll also look into this, but if you haven’t already, consider changing the default view for feeds that need text-mode content to Text, and the app will prefetch the text view so you don’t have to wait for it.