Android: Feed lost will not reinstall

<give us some feedback!>
I noticed that I’d lost my ThinkBroadband feed a few days ago.
I went to their Web site and found that they had made a minor change to the address of their RSS feed.

If I put that into the Add dialogue in, it fails saying there is no RSS FEED.

I tried the plain Web site and the RSS page as https and http.

How can I get it

app version: 10.1b3
android version: 9 (PPR1.180610.011.T820XXU3CTD5)
device: samsung SM-T820 (msm8996)
sqlite version: 3.22.0
username: JimB
server: default
speed: 60 feeds in conn:1006 read:20 parse:52 store:60
pending actions: pre:0 post:0
premium: yes
prefetch: no
notifications: no
keepread: no
thumbs: no

the link you gave for the new feed is https, but your screenshot shows you attempting to add it as http.

Quote from my original post: “I tried the plain Web site and the RSS page as https and http.”

Please can someone help?

If I try to add the feed that is showing stories up to and including today, newsblur says “cannot add feed”. How can it not add when pasting that address into a browser shows the feed?

If I just try to add “thinkbroadband”, newsblur tells me there are 106 subscribers, but it shows the latest post as 28 Aug.

There is a problem. 106 subscribers are not getting any new stories. This is the old feed:-