Android App stuck on Loading Stories

Android App on Stock 4.2.2 Nexus 4

Tapping on All Stories gets stuck on the loading stories screen.

However if I previously viewed a single feed, then clicking on All Stories gives me the entries of that previously viewed single feed. So as of now the app is unusable for me (with 995 subscriptions)


Same problem here.

I believe I have the same problem. See:…

Having a really tricky time reproducing this one (even tried it on a stock N4 with an account with >250 feeds, the biggest I have).

Are you on a paricularly shaky network connection? Running a battery saver / task killer? Does feed view and folder view work allright?

I am thinking that it might be related somehow to the number of subscriptions. Just like Gregor, I have a large number of subscriptions and both the Android app (on a Motorola Droid with 4G) as well as the iPad app just will not work. Checking individual feeds, no problem, but All Stories? Both apps just seem to get stuck.

I only have 57 and I seem to have this problem on an SPH-D710 with JB 4.1.2.

How many feeds? It’s possible the URL you’re trying to hit is too large.

What are your usernames? I’d love to see if we can repro it.

Username is Nrbelex. Also wrote about it here:…


My wifi is fine, no battery saver or task killer.

Folder view and single feed view works.

My username is GregorW

We’ll be launching a fix for this bug tomorrow, as soon as I get the repo cleaned up a bit.

Awesome. Looking forward to it.

This fixed it. All Stories is loading fine for me now, except that it is painfully slow. It takes 36 seconds until the stories appear when I tap “all stories”.

same stuff happens when you choose focus tab and you have more than 20-30 green marked news it also loads them 4ever :frowning:


If the most recent update (available, downloaded and installed this morning - version 2.02) was meant to fix the issue, it doesn’t appear to have worked for me…

Just to be clear, I’m trying to read all (159) available stories from my focus list. After 2 minutes nothing has loaded.

Did the 2.0.2 update do the trick for anybody else?

Yes, it is working for me now. One suggestion, though: I remember from when the iPad app was still working for me (…), that you could mark as read either all articles or just the number of articles that you had just scrolled by. I figured that the Android app would give me a similar choice, but when it hit the “mark as read” button, it marked all 900+ unread items as read, without any warning. Not the end of the world, but annoying nonetheless. In the interest of consistency, similarly labeled buttons should do the same things across apps and if they don’t, it should be made clear that they don’t. Ok, temporarily to the Old Reader for those 900+ articles…:slight_smile:

To be even more precise, I’m trying to read all available stories from my focus list *sorted by oldest and unread*.